Trucsweb.com

Forum de discussion

 Forum « Flash et Shockwave » (archives)

Re: mise a jour correctice I.E. simplifié ;-)

Envoyé: 21 juillet 2006, 10h35 par jeffly


Bonjour,

J'ai executé toutes vos préconisations mais cela ne fonctionne pas.

J'ai mis ce code entre :

<HEAD>
<script language="javascript">AC_FL_RunContent = 0;</script>
<script src="AC_RunActiveContent.js" language="javascript"></script>
</HEAD>

J'ai télécharché le .js sur le lien que vous indiquez :

AC_RunActiveContent.js


Et les phases 3 et 4 dans le même layer
comme ci-dessous.

J'ai simplement ajouté
'wmode', 'transparent',dans le script

<PARAM NAME=wmode VALUE="transparent">
dans "object classid..."

Voila mon code :

<div id="Layer3" STYLE="position: absolute; left:80px; top:-65; width: 32px; height: 32px; z-index:0">
<script language="javascript">
if (AC_FL_RunContent == 0) {
alert("Cette page requiert AC_RunActiveContent.js");
} else {
AC_FL_RunContent(
'codebase', 'https://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0',
'width', '398',
'height', '325',
'src', 'sanspassion.swf',
'quality', 'high',
'pluginspage', 'https://www.macromedia.com/go/getflashplayer',
'align', 'middle',
'play', 'true',
'loop', 'false',
'scale', 'noscale',
'wmode', 'window',
'devicefont', 'false',
'id', 'sanspassion',
'bgcolor', '#eeeeee',
'name', 'sanspassion',
'menu', 'false',
'wmode', 'transparent',
'allowScriptAccess','sameDomain',
'movie', 'sanspassion.swf',
'salign', ''
);
}
</script>


<noscript>
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="https://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
width="398" height="325" id="sanspassion" align="middle">
<param name="allowScriptAccess" value="sameDomain" >
<param name="movie" value="sanspassion.swf" >
<param name="loop" value="false" >
<param name="menu" value="false" >
<param name="quality" value="high" >
<param name="bgcolor" value="#eeeeee" >
<PARAM NAME=wmode VALUE="transparent">
<embed src="sanspassion.swf" loop="false" menu="false" quality="high"
bgcolor="#eeeeee" width="398" height="325" name="sanspassion"
align="middle" allowScriptAccess="sameDomain"
type="application/x-shockwave-flash" pluginspage="https://www.macromedia.com/go/getflashplayer"; >
</object>
</noscript>
</div>

RESULTATS :
plus rien
par contre si je retire 'wmode', 'transparent',dans le script
et
<PARAM NAME=wmode VALUE="transparent">
dans "object classid..."

j'obtiens une case grise fixe.

Je précise que je n'ai rien modifié dans le .js

Si vous pouvez m'aider pour enfin avoir un site nikel, je vous en serais reconnaissant.
Encore merci pour tout.

JEFF


Réponses

 Aucune réponse à ce message... 
Aucun médias sociaux
X

Trucsweb.com Connexion

X

Trucsweb.com Mot de passe perdu

X

Trucsweb.com Conditions générales

Conditions

Responsabilité

La responsabilité des Trucsweb.com ne pourra être engagée en cas de faits indépendants de sa volonté. Les informations mises à disposition sur ce site le sont uniquement à titre purement informatif et ne sauraient constituer en aucun cas un conseil ou une recommandation de quelque nature que ce soit.

Aucun contrôle n'est exercé sur les références et ressources externes, l'utilisateur reconnaît que les Trucsweb.com n'assume aucune responsabilité relative à la mise à disposition de ces ressources, et ne peut être tenue responsable quant à leur contenu.

Droit applicable et juridiction compétente

Les règles en matière de droit, applicables aux contenus et aux transmissions de données sur et autour du site, sont déterminées par la loi canadienne. En cas de litige, n'ayant pu faire l'objet d'un accord à l'amiable, seuls les tribunaux canadien sont compétents.

X

Trucsweb.com Trucsweb

X

Trucsweb.com Glossaire

X

Trucsweb.com Trucsweb

X

Trucsweb.com Trucsweb

Conditions

Aucun message!

Merci.

X
Aucun message!
X

Trucsweb.com Créer un compte